db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kristian Waagan (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-2359) Code cleanups for the org.apache.derby.impl.store.access.* packages
Date Tue, 18 Dec 2007 16:46:43 GMT

    [ https://issues.apache.org/jira/browse/DERBY-2359?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12552812

Kristian Waagan commented on DERBY-2359:

I want to remove the unused parameter 'conglomId' of the method 'getDynamicCompiledConglomInfo'
in the interface 'iapi.store.access.conglomerate.Conglomerate'.
Does anyone see any problems about doing that?

Note that there is another method of the same name and with the same parameter in the interface
'TransactionController'. In this case the parameter is used.

> Code cleanups for the org.apache.derby.impl.store.access.* packages
> -------------------------------------------------------------------
>                 Key: DERBY-2359
>                 URL: https://issues.apache.org/jira/browse/DERBY-2359
>             Project: Derby
>          Issue Type: Improvement
>          Components: Store
>    Affects Versions:
>            Reporter: Kristian Waagan
>            Assignee: Kristian Waagan
>            Priority: Minor
>         Attachments: btreeforwardscan_cleanup.diff, derby-2359-1a-unused_imports.diff,
derby-2359-1a-unused_imports.stat, derby-2359-1b-unused_imports.diff, derby-2359-1b-unused_imports.stat,
derby-2359-2a_method-renames.diff, derby-2359-2a_method-renames.stat, derby-2359-3a-visibility_changes.diff,
> When trying to learn more about the access layer, it was discovered that some code improvements
could easily be made to increase the readability of the code.
> Patches attached to this issue will be cleanup patches only, and no functionality should
be changed. 
> Changes the will/may be made:
>  * remove unused imports
>  * remove unused methods
>  * fix JavaDoc errors
>  * tighter encapsulation and removal of unused variables where appropriate

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message