db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Nielsen (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-3117) Adjust master build script to require the Java 5 compiler to build Derby
Date Thu, 08 Nov 2007 22:22:50 GMT

    [ https://issues.apache.org/jira/browse/DERBY-3117?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12541157
] 

Thomas Nielsen commented on DERBY-3117:
---------------------------------------

derby-3117-01-propertySetter-ae.diff seems to work fine with WinXP / Sun 1.6.0_03 JDK

My sandbox builds fine 
1) with my existing ant.properties in user.home
2) without an ant.properties in user.home, and with JAVA_HOME set to point to my 1.6.0_03
installation

Not sure if this is supposed to be supported - but if I unset JAVA_HOME as well, but keep
both <jdk>/bin and <ant>/bin in my PATH, I get:
---
C:\MyProjects\derby\trunk>ant all testing buildjars
Unable to locate tools.jar. Expected to find it in C:\Program Files\Java\jre1.6.0_03\lib\tools.jar
Buildfile: build.xml

checkCompilerLevel:
    [javac] Warning: z.java modified in the future.
    [javac] Compiling 1 source file

BUILD FAILED
C:\MyProjects\derby\trunk\build.xml:100: Unable to find a javac compiler;
com.sun.tools.javac.Main is not on the classpath.
Perhaps JAVA_HOME does not point to the JDK.
It is currently set to "C:\Program Files\Java\jre1.6.0_03"

Total time: 0 seconds 
---

> Adjust master build script to require the Java 5 compiler to build Derby
> ------------------------------------------------------------------------
>
>                 Key: DERBY-3117
>                 URL: https://issues.apache.org/jira/browse/DERBY-3117
>             Project: Derby
>          Issue Type: Improvement
>          Components: Build tools
>    Affects Versions: 10.4.0.0
>            Reporter: Rick Hillegas
>            Assignee: Rick Hillegas
>         Attachments: BuildDefaults.txt, derby-3117-01-enforceJava5-aa.diff, derby-3117-01-enforceJava5-ab.diff,
derby-3117-01-enforceJava5-ac.diff, derby-3117-02-website-aa.diff, derby-3117-03-junit-aa.diff,
derby-3117-04-propertySetter-aa.diff, derby-3117-04-propertySetter-ab.diff, derby-3117-04-propertySetter-ac.diff,
derby-3117-04-propertySetter-ad.diff, derby-3117-04-propertySetter-ae.diff, derby_source.html
>
>
> Require the Java 5 compiler in order to build Derby as approved by the community recently:
http://www.nabble.com/-VOTE--Require-Java-5-%28or-later%29-compiler-to-build-Derby-tf4522491.html#a13030783

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message