db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Nielsen (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (DERBY-3117) Adjust master build script to require the Java 5 compiler to build Derby
Date Fri, 09 Nov 2007 21:17:50 GMT

    [ https://issues.apache.org/jira/browse/DERBY-3117?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12541444
] 

thomanie edited comment on DERBY-3117 at 11/9/07 1:17 PM:
----------------------------------------------------------------

derby-3117-04-propertySetter-af.diff properly displays the properties it sets (still with
Sun JDK).

But ...
---
setCompilerProperties:
[setJdkProperties] Setting property java14compile.classpath to C:\program files\
java\jdk1.6.0_03\jre\..\..\jdk1.4.2_15\jre\lib\charsets.jar;C:\program files\jav
a\jdk1.6.0_03\jre\..\..\jdk1.4.2_15\jre\lib\jce.jar;C:\program files\java\jdk1.6
.0_03\jre\..\..\jdk1.4.2_15\jre\lib\jsse.jar;C:\program files\java\jdk1.6.0_03\j
re\..\..\jdk1.4.2_15\jre\lib\plugin.jar;C:\program files\java\jdk1.6.0_03\jre\..
\..\jdk1.4.2_15\jre\lib\rt.jar;C:\program files\java\jdk1.6.0_03\jre\..\..\jdk1.
4.2_15\jre\lib\sunrsasign.jar
[setJdkProperties] Setting property java15compile.classpath to C:\program files\
java\jdk1.6.0_03\jre\..\..\jre1.5.0_13\lib\charsets.jar;C:\program files\java\jd
k1.6.0_03\jre\..\..\jre1.5.0_13\lib\deploy.jar;C:\program files\java\jdk1.6.0_03
\jre\..\..\jre1.5.0_13\lib\javaws.jar;C:\program files\java\jdk1.6.0_03\jre\..\.
.\jre1.5.0_13\lib\jce.jar;C:\program files\java\jdk1.6.0_03\jre\..\..\jre1.5.0_1
3\lib\jsse.jar;C:\program files\java\jdk1.6.0_03\jre\..\..\jre1.5.0_13\lib\plugi
n.jar;C:\program files\java\jdk1.6.0_03\jre\..\..\jre1.5.0_13\lib\rt.jar
----
It seems PropertySetter still use 1.5.0_13, even though my JAVA_HOME points to 1.6.0_03. 
1.6 satisfies the 1.5 requirement, so should it not use 1.6 for java15compile.classpath if
my JAVA_HOME points to 1.6?

Not only is it using 1.5, it's actually jumping into the 1.5 jre(!) dir, not the 1.5 JDK jre
dir.

      was (Author: thomanie):
    derby-3117-04-propertySetter-af.diff properly displays the properties it sets (still with
Sun JDK).

But ...
---
setCompilerProperties:
[setJdkProperties] Setting property java14compile.classpath to C:\program files\
java\jdk1.6.0_03\jre\..\..\jdk1.4.2_15\jre\lib\charsets.jar;C:\program files\jav
a\jdk1.6.0_03\jre\..\..\jdk1.4.2_15\jre\lib\jce.jar;C:\program files\java\jdk1.6
.0_03\jre\..\..\jdk1.4.2_15\jre\lib\jsse.jar;C:\program files\java\jdk1.6.0_03\j
re\..\..\jdk1.4.2_15\jre\lib\plugin.jar;C:\program files\java\jdk1.6.0_03\jre\..
\..\jdk1.4.2_15\jre\lib\rt.jar;C:\program files\java\jdk1.6.0_03\jre\..\..\jdk1.
4.2_15\jre\lib\sunrsasign.jar
[setJdkProperties] Setting property java15compile.classpath to C:\program files\
java\jdk1.6.0_03\jre\..\..\jre1.5.0_13\lib\charsets.jar;C:\program files\java\jd
k1.6.0_03\jre\..\..\jre1.5.0_13\lib\deploy.jar;C:\program files\java\jdk1.6.0_03
\jre\..\..\jre1.5.0_13\lib\javaws.jar;C:\program files\java\jdk1.6.0_03\jre\..\.
.\jre1.5.0_13\lib\jce.jar;C:\program files\java\jdk1.6.0_03\jre\..\..\jre1.5.0_1
3\lib\jsse.jar;C:\program files\java\jdk1.6.0_03\jre\..\..\jre1.5.0_13\lib\plugi
n.jar;C:\program files\java\jdk1.6.0_03\jre\..\..\jre1.5.0_13\lib\rt.jar
----
It seems PropertySetter still use 1.5.0_13, even though my JAVA_HOME points to 1.6.0_03. 
1.6 satisfies the 1.5 requirement, so should it not use 1.6 for java15compile.classpath if
my JAVA_HOME points to 1.6?
  
> Adjust master build script to require the Java 5 compiler to build Derby
> ------------------------------------------------------------------------
>
>                 Key: DERBY-3117
>                 URL: https://issues.apache.org/jira/browse/DERBY-3117
>             Project: Derby
>          Issue Type: Improvement
>          Components: Build tools
>    Affects Versions: 10.4.0.0
>            Reporter: Rick Hillegas
>            Assignee: Rick Hillegas
>         Attachments: BuildDefaults.txt, derby-3117-01-enforceJava5-aa.diff, derby-3117-01-enforceJava5-ab.diff,
derby-3117-01-enforceJava5-ac.diff, derby-3117-02-website-aa.diff, derby-3117-03-junit-aa.diff,
derby-3117-04-propertySetter-aa.diff, derby-3117-04-propertySetter-ab.diff, derby-3117-04-propertySetter-ac.diff,
derby-3117-04-propertySetter-ad.diff, derby-3117-04-propertySetter-ae.diff, derby-3117-04-propertySetter-af.diff,
derby_source.html
>
>
> Require the Java 5 compiler in order to build Derby as approved by the community recently:
http://www.nabble.com/-VOTE--Require-Java-5-%28or-later%29-compiler-to-build-Derby-tf4522491.html#a13030783

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message