db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vemund Ostgaard <Vemund.Ostga...@Sun.COM>
Subject Re: Automatic setting of compiler classpath properties at build time
Date Mon, 19 Nov 2007 14:42:24 GMT
Rick Hillegas wrote:
> I have checked in some build logic which automatically sets the 
> compiler classpath properties. This is part of the work on DERBY-3117 
> and the goal,  ultimately, is to have a Derby build script which works 
> out of the box without any customizing of ant.properties.
>
> In order to take advantage of this automatic property setting today, 
> you need to remove some existing properties from your ant.properties 
> (j14lib, j15lib, java14compile.classpath, java15compile.classpath) 
> and, instead, set the following in ant.properties:
>
> autosetProps=on
>
> That is, right now you have to request the automatic setting of 
> properties. A month from now, I would like to make automatic property 
> setting the default. Note that even after automatic property setting 
> becomes the default, you will still be able to override the defaults 
> by setting the properties as you do today.
>
> Over the next month, I would appreciate it if people could try out the 
> automatic property setting in their own environments and let me know 
> if something breaks. I would like this to be as solid as possible 
> before switching the default behavior.
I tried it out in my sandbox Rick, and it worked fine except for one 
thing that probably isn't related to your changes.

The first time I do "ant all" after having done "ant clean" or "ant 
clobber", the build fails when compiling

junitcomponents:
    [javac] Compiling 1 source file to 
/usr/local/cluwin/vo136787/derby/source/trunk/classes
    [javac] Compiling 11 source files to 
/usr/local/cluwin/vo136787/derby/source/trunk/classes
    [javac] 
/usr/local/cluwin/vo136787/derby/source/trunk/java/testing/org/apache/derbyTesting/functionTests/harness/Sed.java:35:

package org.apache.oro.text.regex does not exist
    [javac] import org.apache.oro.text.regex.*;

As far as I can understand, for some reason it cannot find the 
jakarta-oro-2.0.8.jar, but it is in my tools/java/ directory where it is 
supposed to be. When I do "ant all" again, it works, but it fails the 
same way every time I have done clean or clobber before. Any idea?

Vemund

Mime
View raw message