db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Knut Anders Hatlen <Knut.Hat...@Sun.COM>
Subject Re: Javadoc build problems with JDK 1.5 code?
Date Wed, 03 Oct 2007 15:04:44 GMT
Bryan Pendleton <bpendleton@amberpoint.com> writes:

>>   1) Build the javadoc with JAVA_HOME set to a JDK 5 or later
>
> This seems like a reasonable answer to me, since as you say we
> are moving to JDK 1.5 as our base development environment.
>
> But, this doesn't completely fix the problem for me. I get
> many fewer errors, but I still get some (see below).

Hi Bryan,

I don't know why you are seeing these errors and I am not, but it seems
like build.xml sets the source level for the javadoc to 1.4:

    <javadoc
        executable="${javadoc.tool}"
        additionalparam="-J-mx320M"
        packagenames="org.*"
        access="private"
        breakiterator="yes"
        useexternalfile="yes"
        classpath="${out.dir};${java14compile.classpath};${jars.extras};${osgi}"
        destdir="${out.javadoc.dir}/engine"
        windowtitle="Apache Derby V${major}.${minor} Internals"
        doctitle="Apache Derby V${major}.${minor} Internals"
        Footer="${javadoc.Footer}"
        bottom="Apache Derby V${major}.${minor} Internals - &lt;i&gt;Copyright &amp;copy;
2004,2007 The Apache Software Foundation. All Rights Reserved.&lt;/i&gt;"
        source="1.4">

If changing the source level to 1.5 fixes it for you, I suggest that we
just cross our fingers and hope that no one vetos the JDK 5 vote (the
polls close at 5 pm PDT today) and check in the fix tomorrow. :)

-- 
Knut Anders

Mime
View raw message