db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Knut Anders Hatlen (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-3117) Adjust master build script to require the Java 5 compiler to build Derby
Date Mon, 08 Oct 2007 18:32:50 GMT

    [ https://issues.apache.org/jira/browse/DERBY-3117?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12533182
] 

Knut Anders Hatlen commented on DERBY-3117:
-------------------------------------------

Looks good! I tried to compile with JAVA_HOME pointing to a 1.4 installation, and I got a
very clear error message. Worked fine with 1.6.

My only comment is to this part of the patch:

-(2) The Derby build environment is tested with 
-    JDK 142(Sun) and Ant 161. The Derby build environment should
+(2) The Derby build environment is tested with Sun's Java 5 compiler,
+    with Sun's JDK 1.4.2 libraries, and with Ant 161. The Derby build environment should
     work with other versions and other sources of 
-    JDK 14 (1.4.x), and other versions of Ant 1.6 (1.6.x).
+    Java 5 and  JDK 14 (1.4.x) and with other versions of Ant 1.6 (1.6.x).

One of the lines exceeded 80 characters. Also, Ant 161 should probably be 1.6.1 (if that's
the version you have tested it with), and JDK 14 should be 1.4.

I think it would also be good to change the link in

+(4) Download the Java 5 or later JDK.
+    The reference implementation is available at:
+       http://java.sun.com/j2se

to its new name http://java.sun.com/javase/.

> Adjust master build script to require the Java 5 compiler to build Derby
> ------------------------------------------------------------------------
>
>                 Key: DERBY-3117
>                 URL: https://issues.apache.org/jira/browse/DERBY-3117
>             Project: Derby
>          Issue Type: Improvement
>          Components: Build tools
>    Affects Versions: 10.4.0.0
>            Reporter: Rick Hillegas
>            Assignee: Rick Hillegas
>         Attachments: derby-3117-01-enforceJava5-aa.diff
>
>
> Require the Java 5 compiler in order to build Derby as approved by the community recently:
http://www.nabble.com/-VOTE--Require-Java-5-%28or-later%29-compiler-to-build-Derby-tf4522491.html#a13030783

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message