db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Knut Anders Hatlen (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-3117) Adjust master build script to require the Java 5 compiler to build Derby
Date Fri, 26 Oct 2007 10:02:50 GMT

    [ https://issues.apache.org/jira/browse/DERBY-3117?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12537908
] 

Knut Anders Hatlen commented on DERBY-3117:
-------------------------------------------

Hi Rick,

On many platforms, Sun's JDK is installed in a directory whose name contains the update number
in addition to the version number (i.e., jdk1.5.0_13), so we may need a more intelligent way
to find the installed JDKs. Does ant support getting a list of, say, all directories matching
jdk1.5.0* and picking one of them?

On Solaris 10 (which comes with JDK 1.4.2 and JDK 5.0 in the default installation), these
are the default directories:

j14lib=${java.home}/../../../j2sdk1.4.2_XX/jre/lib (where XX is the update number)
j15lib=${java.home}/../../jdk1.5.0/jre/lib

(given that the JAVA_HOME environment variable is not set and /usr/bin/java is the first java
command found in your PATH)

and

java14compile.classpath=${j14lib}/rt.jar;${j14lib}/jce.jar;${j14lib}/jsse.jar
java15compile.classpath=${j15lib}/rt.jar;${j15lib}/jce.jar;${j15lib}/jsse.jar

> Adjust master build script to require the Java 5 compiler to build Derby
> ------------------------------------------------------------------------
>
>                 Key: DERBY-3117
>                 URL: https://issues.apache.org/jira/browse/DERBY-3117
>             Project: Derby
>          Issue Type: Improvement
>          Components: Build tools
>    Affects Versions: 10.4.0.0
>            Reporter: Rick Hillegas
>            Assignee: Rick Hillegas
>         Attachments: BuildDefaults.txt, derby-3117-01-enforceJava5-aa.diff, derby-3117-01-enforceJava5-ab.diff,
derby-3117-01-enforceJava5-ac.diff, derby-3117-02-website-aa.diff, derby_source.html
>
>
> Require the Java 5 compiler in order to build Derby as approved by the community recently:
http://www.nabble.com/-VOTE--Require-Java-5-%28or-later%29-compiler-to-build-Derby-tf4522491.html#a13030783

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message