db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Pendleton <bpendle...@amberpoint.com>
Subject Re: [VOTE] Require Java 5 (or later) compiler to build Derby
Date Thu, 04 Oct 2007 14:32:39 GMT
>> Seems that it might be possible with this to start using some 1.5 
>> language constructs in Derby's code: those that compile down to 
>> standard byte code. This would be by using -source 1.5 -target 1.4 in 
>> the build.xml files.
> 
> Be *very* careful about what 1.5 language features you start using in 
> your code. It's not as easy as specifying -source 1.5 -target 1.4 to get 
> a 1.4 compatible class/jar.
> 
> If you end up using the "wrong" language constructs in your code, you 
> will become dependant on additional libraries like Retrowaver (or 
> similar) that implements the missing features/classes for you.

Thanks Thomas! Existing experience here is very helpful.

Perhaps you could start a wiki page about this, and collect any
specific information that you recall from your prior experiences
of mixing and matching language features, and then as we figure out
additional conventions about what works, and what doesn't, we can
add them to the wiki page.

thanks,

bryan



Mime
View raw message