db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Nielsen <Thomas.Niel...@Sun.COM>
Subject Re: [VOTE] Require Java 5 (or later) compiler to build Derby
Date Thu, 04 Oct 2007 07:30:34 GMT
Daniel John Debrunner wrote:
> Seems that it might be possible with this to start using some 1.5 
> language constructs in Derby's code: those that compile down to standard 
> byte code. This would be by using -source 1.5 -target 1.4 in the 
> build.xml files.

Be *very* careful about what 1.5 language features you start using in 
your code. It's not as easy as specifying -source 1.5 -target 1.4 to get 
a 1.4 compatible class/jar.

If you end up using the "wrong" language constructs in your code, you 
will become dependant on additional libraries like Retrowaver (or 
similar) that implements the missing features/classes for you.

In a former life we ended up writing 1.4 code and compiled using a 1.5 
compiler to avoid additional dependencies.

"-target jsr14" seem to be supported now (it wasn't back then), and 
might solve this issue.

Thomas
-- 
Thomas Nielsen

Mime
View raw message