db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel John Debrunner <...@apache.org>
Subject Re: [VOTE] Require Java 5 (or later) compiler to build Derby
Date Wed, 03 Oct 2007 23:15:24 GMT
Rick Hillegas <Richard.Hillegas@Sun.COM> writes:

>> Please vote on whether we should require that developers use a Java 5
>> (or later) compiler in order to build Derby. This means that the shell
>> window running the build should have its JAVA_HOME pointed at a Java 5
>> or later jdk and the corresponding javac should be what's visible on
>> PATH. The practical implication of this change is that the Derby build
>> will fail when run from a jdk1.4 environment.

+1

Seems that it might be possible with this to start using some 1.5 
language constructs in Derby's code: those that compile down to standard 
byte code. This would be by using -source 1.5 -target 1.4 in the 
build.xml files.

Examples are the for each loop, auto-boxing and some annotations. 
Something to try out anyway ...

Dan.

Mime
View raw message