db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rick Hillegas (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-3117) Adjust master build script to require the Java 5 compiler to build Derby
Date Thu, 25 Oct 2007 17:29:50 GMT

    [ https://issues.apache.org/jira/browse/DERBY-3117?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12537664

Rick Hillegas commented on DERBY-3117:

Hi Dan,

Could you explain the problem that you are seeing when running the ant junit tests on jdk
1.4 or J2ME? I have started up the tests via "ant junit-all" in a shell window whose  $JAVA_HOME
is set to jdk 1.4. The tests are running without error so far. If the initialization check
were going to interfere with this test run, I would expect that the interference would happen
when the tests start and the test run would fail fast. Thanks.

> Adjust master build script to require the Java 5 compiler to build Derby
> ------------------------------------------------------------------------
>                 Key: DERBY-3117
>                 URL: https://issues.apache.org/jira/browse/DERBY-3117
>             Project: Derby
>          Issue Type: Improvement
>          Components: Build tools
>    Affects Versions:
>            Reporter: Rick Hillegas
>            Assignee: Rick Hillegas
>         Attachments: BuildDefaults.txt, derby-3117-01-enforceJava5-aa.diff, derby-3117-01-enforceJava5-ab.diff,
derby-3117-01-enforceJava5-ac.diff, derby-3117-02-website-aa.diff, derby_source.html
> Require the Java 5 compiler in order to build Derby as approved by the community recently:

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message