db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rick Hillegas (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-3117) Adjust master build script to require the Java 5 compiler to build Derby
Date Mon, 29 Oct 2007 15:50:50 GMT

    [ https://issues.apache.org/jira/browse/DERBY-3117?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12538527
] 

Rick Hillegas commented on DERBY-3117:
--------------------------------------

Hi Dan,

There is a catch-22 with building the ant task, but I'm hoping it's relatively minor. Basically,
the build tools would be built with whatever compiler is visible in $JAVA_HOME together with
its default understanding of what the bootclasspath is. I think the trick here is that our
build tasks (the <javac> calls) are setting bootclasspath to ${empty}, which forces
<javac> to rely on follow-on <classpath> declarations to contain the location
of the JDK jars. So the idea would be to invoke <javac> on the buildtools directory
without forcing bootclasspath to ${empty}. I think this creates a small possibility that someone
could introduce a Java6-specific reference into the buildtools and we wouldn't notice this
until someone else tried to compile Derby in a Java 5 environment. I think I could live with
that exposure.

Of course, I haven't mocked this up yet and there could be a bigger catch-22!

> Adjust master build script to require the Java 5 compiler to build Derby
> ------------------------------------------------------------------------
>
>                 Key: DERBY-3117
>                 URL: https://issues.apache.org/jira/browse/DERBY-3117
>             Project: Derby
>          Issue Type: Improvement
>          Components: Build tools
>    Affects Versions: 10.4.0.0
>            Reporter: Rick Hillegas
>            Assignee: Rick Hillegas
>         Attachments: BuildDefaults.txt, derby-3117-01-enforceJava5-aa.diff, derby-3117-01-enforceJava5-ab.diff,
derby-3117-01-enforceJava5-ac.diff, derby-3117-02-website-aa.diff, derby-3117-03-junit-aa.diff,
derby_source.html
>
>
> Require the Java 5 compiler in order to build Derby as approved by the community recently:
http://www.nabble.com/-VOTE--Require-Java-5-%28or-later%29-compiler-to-build-Derby-tf4522491.html#a13030783

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message