db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rick Hillegas (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-3117) Adjust master build script to require the Java 5 compiler to build Derby
Date Fri, 26 Oct 2007 20:34:50 GMT

    [ https://issues.apache.org/jira/browse/DERBY-3117?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12538095
] 

Rick Hillegas commented on DERBY-3117:
--------------------------------------

Hi Knut,

You raise a good point here. This gets to be a little tricky to do in an xml script-my experience
is that xml is a lousy language in which to write procedural code. Fortunately, there's a
trapdoor for this kind of problem, viz.,  you write a custom ant Task. The Task would have
to be compiled before we needed to look at jdk14, jdk15, java14comple.classpath, and java15compile.classpath.
The Task could use org.apache.tools.ant.taskdefs.Property  to set those properties based on
the JDK vendor, the operating system, and $JAVA_HOME. I could write this task and plug in
the logic for Max OS X. Other people could plug in the logic for their favorite build environments
later on. And of course, the current model of forcibly setting values in ant.properties would
continue to work.

> Adjust master build script to require the Java 5 compiler to build Derby
> ------------------------------------------------------------------------
>
>                 Key: DERBY-3117
>                 URL: https://issues.apache.org/jira/browse/DERBY-3117
>             Project: Derby
>          Issue Type: Improvement
>          Components: Build tools
>    Affects Versions: 10.4.0.0
>            Reporter: Rick Hillegas
>            Assignee: Rick Hillegas
>         Attachments: BuildDefaults.txt, derby-3117-01-enforceJava5-aa.diff, derby-3117-01-enforceJava5-ab.diff,
derby-3117-01-enforceJava5-ac.diff, derby-3117-02-website-aa.diff, derby-3117-03-junit-aa.diff,
derby_source.html
>
>
> Require the Java 5 compiler in order to build Derby as approved by the community recently:
http://www.nabble.com/-VOTE--Require-Java-5-%28or-later%29-compiler-to-build-Derby-tf4522491.html#a13030783

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message