db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Knut Anders Hatlen <Knut.Hat...@Sun.COM>
Subject Re: Requiring Java 5 compiler
Date Wed, 19 Sep 2007 08:16:08 GMT
Mike Matrigali <mikem_app@sbcglobal.net> writes:

> Rick Hillegas wrote:
>> Mike Matrigali wrote:
>>> What about requiring jdk1.5 or higher for both building and running
>>> for the next release made off of trunk?
>>> /mikem
>> Would this involve abandoning support for small devices? I think
>> that CDC is still based on the 1.4 platform.
> This is a good question, we should resolve this before going forward.  I
> don't know the answer.  It would seem like a good thing to allow future
> versions for derby to support JSR169/J2ME - does anyone know if this can
> be done with jdk1.5 compiler/libraries.  This is a nice feature for
> an open source db that can't be provided by a lot of other db's.
> Maybe it can be done, but it has always seemed safer to me to always
> support building in the lowest jvm environment that we support running
> in.  If we really want to support building in 1.5 but running in 1.4
> how do make sure we don't have 1.5 library dependencies in critical
> portions of the code.

I don't think this is how it has been done before. Even when we
supported running Derby in 1.3, we required 1.4 to build Derby. The
problem with library dependencies was solved by compiling the Java 1.3
parts with source/target=1.3 and pointing compile.classpath to the 1.3
runtime library.

Knut Anders

View raw message