db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Van Couvering" <da...@vancouvering.com>
Subject Re: Requiring Java 5 compiler
Date Fri, 21 Sep 2007 21:07:58 GMT
I think J2ME support is very important.

As another data point, NB requires that you build in JDK 1.5 just for
the reason you state, Mike: to avoid accidental use and checkin of JDK
1.6-specific features.  The ant script actually prevents you from
compiling with JDK 1.6 unless you set a specific property that
basically is like you signing a form saying "I know this is dangerous,
I'm willing to take the risk."

At the same time, oddly enough, it is a requirement that even though
you shouldn't compile in JDK 1.6, we should be able to.  It's
considered a P2 bug if the compile breaks on 1.6.

I learned this the hard way when we had some rowset code that didn't
implement the new ResultSet methods in JDBC.

David

On 9/18/07, Mike Matrigali <mikem_app@sbcglobal.net> wrote:
>
>
> Rick Hillegas wrote:
> > Mike Matrigali wrote:
> >> What about requiring jdk1.5 or higher for both building and running
> >> for the next release made off of trunk?
> >> /mikem
> > Would this involve abandoning support for small devices? I think that
> > CDC is still based on the 1.4 platform.
>
> This is a good question, we should resolve this before going forward.  I
> don't know the answer.  It would seem like a good thing to allow future
> versions for derby to support JSR169/J2ME - does anyone know if this can
> be done with jdk1.5 compiler/libraries.  This is a nice feature for
> an open source db that can't be provided by a lot of other db's.
>
> Maybe it can be done, but it has always seemed safer to me to always
> support building in the lowest jvm environment that we support running
> in.  If we really want to support building in 1.5 but running in 1.4
> how do make sure we don't have 1.5 library dependencies in critical
> portions of the code.
>
> Depending on the j2me answer i think the time is soon to move our
> minimum support from jdk14 to jdk15.  The question is if the next major
> release is too soon or not.  It seems like we should move either in
> the next release or the one after that.  More and more useful features
> are being added that require jdk15 support and people have to jump
> some hoops to use these (alternate build targets, multiple
> implementations, call by reflection, ...).
> >
> > Thanks,
> > -Rick
> >>
> >> Rick Hillegas wrote:
> >>> I would like to start writing Derby code which makes use of Java 5
> >>> features. More specifically:
> >>>
> >>> 1) I would like to take advantage of the Java 5 extensions for
> >>> ease-of-use and stronger type checking.
> >>>
> >>> 2) I would like to be able to write regression tests which verify
> >>> that user-written Java 5 code runs correctly as Derby functions and
> >>> procedures.
> >>>
> >>> Would anyone object to our requiring that developers use a Java 5 or
> >>> later compiler to build Derby? I believe that we would still require
> >>> the presence of the 1.4 libraries and the expectation would continue
> >>> to be that the compiler must compile down to 1.4 classes.
> >>>
> >>> Thanks,
> >>> -Rick
> >>>
> >>>
> >>>
> >
> >
>

Mime
View raw message