db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Matrigali <mikem_...@sbcglobal.net>
Subject Re: [VOTE] Require Java 5 (or later) compiler to build Derby
Date Wed, 26 Sep 2007 18:19:37 GMT
If I only have jdk1.5 environment will the build succeed, and if so will
it identify if I have somehow used a jdk1.5 specific library function in
a "non-optional" part of the code?

How is optional vs. non-optional code specified?  Is this an ant xml 
file property in the directory for the code?

/mikem

Rick Hillegas wrote:
> Please vote on whether we should require that developers use a Java 5 
> (or later) compiler in order to build Derby. This means that the shell 
> window running the build should have its JAVA_HOME pointed at a Java 5 
> or later jdk and the corresponding javac should be what's visible on 
> PATH. The practical implication of this change is that the Derby build 
> will fail when run from a jdk1.4 environment.
> 
> Please note that, even after this vote, we still expect the following to 
> hold:
> 
> 1) All mandatory Derby code must still be at jdk1.4 (or earlier) level. 
> The build will still compile mandatory code into classes that run on 
> jdk1.4.
> 
> 2) Derby 10.4 will continue to run on the same platforms that 10.3 
> does--including the CDC small platforms.
> 
> This change will make the following possible:
> 
> A) Optional product code can be written which takes advantage of Java 5 
> features. This code will only run if Derby detects that it is running on 
> a vm at level Java 5 or later.
> 
> B) Test code can be written to make sure that Derby correctly interacts 
> with user code which is at Java 5 level or later.
> 
> This is a lazy consensus vote. The polls close at 5:00 pm on Wednesday 
> October 3.
> 
> Regards,
> -Rick
> 


Mime
View raw message