db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <Richard.Hille...@Sun.COM>
Subject Re: Requiring Java 5 compiler
Date Tue, 25 Sep 2007 13:14:20 GMT
Kathey Marsden wrote:
> Stanley Bradbury wrote:
>> I am concerned that this proposal includes dropping support for J2ME 
>> from Derby.    I would like to see a standard vote if this does mean 
>> dropping the J2ME platform.  IMHO it would also be good to poll the 
>> User community specifically about the use of J2ME to determine if 
>> such a change will leave some applications without an upgrade path.
> Rick could you clarify this. I had thought that  that we would still  
> support J2ME and jdk 1.4.2 and that this is  a change that would only 
> affect developers building Derby, not users running Derby. Is that 
> correct?
>
> Thanks
>
> Kathey
>
Hi Kathey,

Yes, that's correct. Product code will continue to be at 1.4 source 
level, it will be compiled down to 1.4 class targets, and the resulting 
product classes will continue to run on J2ME and on jdk1.4. Derby 10.4 
will run on all of the platforms that 10.3 does.

It should be possible, however, to build optional Java 5 code. Derby 
would only use this code if Derby detected that it was running on a Java 
5 (or later) platform.

I hope this is clearer.

Regards,
-Rick

Mime
View raw message