db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Pendleton <bpendle...@amberpoint.com>
Subject Re: Requiring Java 5 compiler
Date Fri, 21 Sep 2007 19:06:50 GMT
> I propose that we require Java 5 (or higher) in order to build Derby. 

This is mostly an implementation issue, but it would be nice if you
could make the build files be as careful as possible about giving a
good message when the environment is incorrect.

I find myself periodically jumping around between builds of 10.2,
10.3, and the trunk, and I'm hoping to minimize the amount of
build environment re-jiggering that I have to do when I do this.

For example, it would be nice if I could maintain a single ant.properties
file and have it work for both my trunk builds and my 10.2/10.3 builds.

thanks,

bryan


Mime
View raw message