db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Øystein Grøvlen (JIRA) <j...@apache.org>
Subject [jira] Commented: (DERBY-2954) Add commands to NetworkServerControl for interacting with the replication functionality
Date Tue, 28 Aug 2007 10:03:30 GMT

    [ https://issues.apache.org/jira/browse/DERBY-2954?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12523207

Øystein Grøvlen commented on DERBY-2954:

I have looked at the patch it looks good.  I think my major comment is
more about the way NetworkServerControlImpl is implemented, and I do
not expect this to be fixed by this patch.  It seems that dashed
arguments that are allowed for one command, is accepted by all
commands.  This problem becomes more evident now since several new
arguments are introduced that does only apply to the replication
commands. Originally, I think all commands had the same set of
arguments, but earlier 'trace' got a -s argument and 'start' the
-noSecurityManager argument.  Hence, this is not the first patch that
has this problem.  However, this patch creates some new issues that
needs to be considered:

1. If I give a non-int argument value to -slaveport, the command is
   silently ignored without any error message (e.g., 'shutdown
   -slaveport x' does not shut down the server, and 'startmaster
   -slaveport x' does not cause the 'not implemented' message to be

2. The empty string is accepted as a command. 
   'java -jar jars/sane/derbyrun.jar server ""' returns without error.

Other comments:

3. I suggest to call the command 'failover' not 'startfailover' since
   this is an action, not a process that will continue until it is
   stopped by another command. 

4. I am starting to think that 'startreplication' may be a better name
   than 'startmaster'.  That will give similar names for starting and
   stopping replication.

5. I think a comment is needed to explain the presence of the empty
   string in the COMMANDS array.

6. I do not think the synchronization in setReplicationDB is needed.
   The client is not going to be multi-threaded.  It is the server
   part of the code that needs synchronization.  (I think it has been
   discussed to split this class to have separate classes for client
   and server code to make this clearer.)

7. I think the text of the DRDA_Slaveurl.I message should use the term
   'host' instead of 'url' since that is the term used by the usage

8. I suggest to change the usage text for the arguments of -slavehost
   and -slaveport to '<host>' and '<portnumber>'.

9. I would think all the new commands will allow the -p, -h, and -ssl
   arguments also, and the usage message should be updated to reflect

> Add commands to NetworkServerControl for interacting with the replication functionality
> ---------------------------------------------------------------------------------------
>                 Key: DERBY-2954
>                 URL: https://issues.apache.org/jira/browse/DERBY-2954
>             Project: Derby
>          Issue Type: Sub-task
>    Affects Versions:
>            Reporter: V.Narayanan
>            Assignee: V.Narayanan
>         Attachments: NetworkServerControlCmds_v1.diff, NetworkServerControlCmds_v1.stat,
NetworkServerControlCmds_v2.diff, NetworkServerControlCmds_v2.stat

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message