db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel John Debrunner (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-2976) DatabaseMetaData.getTables fails for databases created with older versions of Derby
Date Wed, 25 Jul 2007 14:37:31 GMT

    [ https://issues.apache.org/jira/browse/DERBY-2976?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12515308
] 

Daniel John Debrunner commented on DERBY-2976:
----------------------------------------------

Not sure this is an issue. 10.3.1.3 and 10.3.1.2 are not official releases but release candidates.

"Databases created by official Derby releases will be upgradable to future versions."

See the warnings here:

http://db.apache.org/derby/dev/derby_source.html#Development+trunk

and for the trunk ...

"It [trunk] may create on-disk database formats that are not upgradable to future releases
of Derby. "




> DatabaseMetaData.getTables fails for databases created with older versions of Derby
> -----------------------------------------------------------------------------------
>
>                 Key: DERBY-2976
>                 URL: https://issues.apache.org/jira/browse/DERBY-2976
>             Project: Derby
>          Issue Type: Bug
>          Components: JDBC
>    Affects Versions: 10.3.1.2, 10.3.1.3, 10.4.0.0
>            Reporter: Jørgen Løland
>            Priority: Critical
>
> Reported by Tim Dudgeon:
> http://www.nabble.com/DatabaseMetaData.getTables%28%29-problems-for-10.3.1.3-with-a-10.3.1.2-database-t4141271.html
> "I'm seeing an exception for the DatabaseMetaData.getTables() method when 
> using 10.3.1.3 with a database that has been upgraded to 10.3.1.2.
> 10.2 databases that have not been upgraded seem to be OK."

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message