db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Knut Anders Hatlen <Knut.Hat...@Sun.COM>
Subject Re: J2ME rev level
Date Tue, 31 Jul 2007 21:51:22 GMT
Rick Hillegas wrote:
> Thanks, Knut. This is very helpful. So here's a revised summary:
> 
> 1) Derby 10.3 will NOT run on a CDC/Foundation 1.0 implementation. 
> Attempts to do so will raise UnsupportedClassVersionError.
> 
> 2) Derby 10.3 will run on CDC/Foundation 1.1 implementations. In this 
> configuration, Derby satisfies the stripped down JDBC api of JSR 169 
> rather than JDBC 3.0 or 4.0.

Thanks Rick, this sounds correct to me (although I've never actually 
tested it). Perhaps someone who uses these platforms could verify it.

-- 
Knut Anders

Mime
View raw message