db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <Richard.Hille...@Sun.COM>
Subject Re: J2ME rev level
Date Mon, 30 Jul 2007 19:53:46 GMT
Myrna van Lunteren wrote:
> On 7/30/07, Rick Hillegas <Richard.Hillegas@sun.com> wrote:
>   
>> What rev level of CDC/Foundation are we claiming to support in 10.3?
>> CDC/Foundation 1.0 or CDC/Foundation 1.1? I notice that the 10.3 code
>> includes calls to Throwable.initCause(), which I thought was not
>> supported in CDC/Foundation 1.0. See
>> http://issues.apache.org/jira/browse/DERBY-2210
>>
>> Thanks,
>> -Rick
>>
>>     
> I thought DERBY-2210 and DERBY-2228 indicate the move to Foundation 1.1.
> But, these issues do say it was supposed to be backwards compatible to
> 1.0, I think?
>
> Which may not be true because of DERBY-2472... & revision 520663...and others?
>
> Myrna
>   
Thanks for pointers to those other JIRAs, Myrna. It looks as though the 
following may be the case:

1) Derby implements the CDC/Foundation 1.0 api.

2) However, Derby runs on CDC/Foundation 1.1 implementations provided 
that the application does not invoke any incremental api introduced by 
CDC/Foundation 1.1.

3) When run on a CDC/Foundation 1.0 implementation, Derby may raise 
method-not-found exceptions. This may happen if Derby error processing 
tries to invoke Throwable.initCause().

Regards,
-Rick


Mime
View raw message