db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myrna van Lunteren (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-2963) AccessControlException: Access denied java.net.SocketPermission <client ip> accept,resolve
Date Sun, 22 Jul 2007 14:52:06 GMT

    [ https://issues.apache.org/jira/browse/DERBY-2963?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12514473
] 

Myrna van Lunteren commented on DERBY-2963:
-------------------------------------------


:-) See the problem description of this bug:

Dan wrote:

I was pretty sure this is what you'd say, - derbyrun.jar kicks off
NetworkServerControl - but I just wanted to be sure.

My next questions are:
- what is the difference between this approach and the steps you
tested that worked for ipv6 for DERBY-2874?
and to pinpoint the problem better:
- does the current problem happen with 10.3.0.0 beta? 10.3.1.1?
- does the problem occur with 10.2.2.0 when security policy is enabled
(i.e. is it a problem with the security policy being on by default, or
is it a more insidious problem with network server. I'm asking because
Dan reported the problem does not occur with 10.3.1.2 when the server
is started with -noSecurityManager).

I hope someone with access to an IPV6 can go through the hoops of
providing these answers, or someone with understanding of the problem
can come forward and fix it.
I believe Rick, who implemented the secure server by default (&fixed
DERBY-2874) is not available this week to fix anything, so if it's in
that area we may have to wait for more than a week for a fix unless
someone else steps up...

Myrna


> AccessControlException: Access denied java.net.SocketPermission <client ip> accept,resolve
> ------------------------------------------------------------------------------------------
>
>                 Key: DERBY-2963
>                 URL: https://issues.apache.org/jira/browse/DERBY-2963
>             Project: Derby
>          Issue Type: Bug
>          Components: Network Server
>    Affects Versions: 10.3.1.2
>         Environment: SuseLinux 10
> IBM JVM 1.5
>            Reporter: Daniel John Debrunner
>            Priority: Blocker
>
> I start the server using an ipv4 address
> java derbyrun.jar server start -h x.x.x.x
> Then I connect from a remote client  and hit an AccessControlException
> The ip in the exception is that of the *client*, not the server.
> This setup works in 10.2.2.0.
> Same problem if the hostname is in derby.properties
> Problem can be worked around by using -noSecurityManager when starting the server

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message