db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Knut Anders Hatlen <Knut.Hat...@Sun.COM>
Subject Re: 10.3 upgrade test on mac, anyone see failures?
Date Fri, 29 Jun 2007 08:14:08 GMT
Myrna van Lunteren <m.v.lunteren@gmail.com> writes:

> Hi,
>
> I ran suites.All with 10.3.1.0 beta on a mac OS X, and I get 69
> failures and 17 errors.
> I tried specifying no oldReleasePath, an incorrect oldReleasePath, and
> a correct oldReleasePath, all giving me the same result.
> I'm currently out of ideas.
>
> Is there anyone else who has a mac that can confirm/counter this for me?

Hi Myrna,

This could be DERBY-1 which prevented DB creation on OS X and BSDs with
a buggy JVM. You can check whether you have a buggy JVM by booting a
database with 10.3 or trunk and see if derby.log contains this message
(added in DERBY-2020):

------------ BEGIN ERROR MESSAGE -------------

LogToFile.checkJvmSyncError: Your JVM seems to have a problem with
implicit syncing of log files. Will use explicit syncing instead.
------------ END ERROR MESSAGE -------------

So what happens, is not that the upgrade fails, but that 10.0 and some
of the 10.1 releases (don't remember which) can't create the database.

-- 
Knut Anders

Mime
View raw message