db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel John Debrunner <...@apache.org>
Subject Re: problems building j2me
Date Wed, 13 Jun 2007 19:27:01 GMT
Mike Jarmy wrote:

> 
> FYI -- For anyone else reading this thread, JclMax is a superset of J2ME 
> which includes quite a few more classes, but sadly java.sql.* is not 
> among them.


What environment are you running in? JCLMax is not any official Java 
profile so it may or may not work with Derby. Derby works on 
J2ME/CDC/Foundation 1.0/1.1, jdk 1.3, jdk 1.4, jdk 1.5 & jdk6.

If you run

java org.apache.derby.tools.sysinfo

and send the output it will be a help. There is a line that indicates 
what Derby thinks the JVM support level is:

E.g. I see this in JDK 1.4.2

--------- Derby Information --------
JRE - JDBC: J2SE 1.4.2 - JDBC 3.0

Dan.



Mime
View raw message