db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <Richard.Hille...@Sun.COM>
Subject Re: errors in junit tests
Date Tue, 05 Jun 2007 12:59:16 GMT
Thanks Myrna and Julo,

I ran the tests with derbyTesting.oldReleasePath set so that the "lib" 
level was skipped in untarred old release distributions. Then the junit 
tests all passed cleanly for me too--that is, the upgrade tests and the 
DatabaseClassLoadingTest all ran cleanly.

Regards,
-Rick

Julius Stroffek wrote:
> Hi Rick,
>
> that seems to be mostly those tests I used to have failures couple of
> days ago.
>
> Just couple of hours ago I started tests of revision #544424. Everything
> finished without any failures to me.
>
> I used -DderbyTesting.oldReleasePath=<location of old release jars>
> which I checked out from https://svn.apache.org/repos/asf/db/derby/jars
> as suggested by Narayanan couple of days ago and Myrna is explaining
> below.
>
> If I run the tests without oldReleasePath specified it does not succeed
> to find the releases from the apache site. I have to use proxy to
> connect to internet so I would expect that there might be an issue with
> a proxy setup.
>
> Does anybody know how can I setup the proxy for upgradeTests? I tried to
> use 'jcontrol' to set it up but that seems to be not sufficient.
>
> Cheers
>
> Julo
>
> On Mon, 2007-06-04 at 11:26 -0700, Myrna van Lunteren wrote:
>   
>> On 6/4/07, Rick Hillegas <Richard.Hillegas@sun.com> wrote:
>>     
>>> I synced my client to revision 544150 this morning. I see 70 failures
>>> and 21 errors when I run the junit tests. The errors are in the
>>> DatabaseClassLoadingTest and the upgrade tests:
>>>
>>> Errors:
>>>
>>> 1)
>>> testLoadJavaClassDirectly(org.apache.derbyTesting.functionTests.tests.lang.DatabaseClassLoadingTest)java.sql.SQLException:
>>> Jar file 'MY_JAVA' already exists in Schema 'EMC'.
>>>       
>> [snip similar\
>>     
>>> 5)
>>> changeEncryptionFromNone(org.apache.derbyTesting.functionTests.tests.upgradeTests.Changes10_2)java.sql.SQLException:
>>> Failed to start database 'singleUse/oneuse29', see the next exception
>>> for details.
>>>       
>> [snipt other upgrade test trouble]
>>
>> Hi Rick,
>>
>> I don't know about the DatabaseClassLoadingTest issues...
>> You didn't say what you were sync-ed up to before (I don't usually
>> check this either), and I'm not sure if you previously ran with
>> -DoldReleasePath to point to derby.jar files for the older releases?
>> The upgrade test logic was changed to not use 'lib' directories in the
>> older releases, and to attempt to find older releases from the apache
>> site unless -DoldReleasePath is set.
>>
>> HTH
>> Myrna
>>     
>
>   


Mime
View raw message