db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel John Debrunner <...@apache.org>
Subject Re: Can't upgrade from 10.1 to 10.3
Date Mon, 04 Jun 2007 17:49:24 GMT
Dag H. Wanvik wrote:
> Stanley Bradbury <Stan.Bradbury@gmail.com> writes:
> 
>> Am I missing something?  Has anyone successfully done the following
>> upgrade?: I am not able to perform a hard upgrade from 10.1 to 10.3
>> [am setting the ...PreReleaseUpgrade=true and using  10.3.0.0 alpha - 
>> (543348)].  When I attempt to hard upgrade a 10.1 DB that requires
>> authentication and has three valid users none of the logons are
>> allowed to upgrade.  The error is:
>> ij version 10.3
>> ij> connect 'jdbc:derby:tstDB;upgrade=true;user=stan;password=xyzzy1';
>> ERROR 08004: User 'STAN' cannot hard upgrade database 'tstDB'. Only
>> the database owner can perform this operation.
> 
> This is because the database was created with an other effective user,
> which then became the database owner. If authentication was not
> enabled at the time of creation and no specific user given, the owner
> would be "APP". The docs changes for DERBY-2264 warm against this
> "gotcha".  A work-around is to make "APP" a valid user, if it is not
> already one.

Shouldn't an upgrade from 10.1 change the database owner to the one 
performing the upgrade? That's what DERBY-1544 states.

http://issues.apache.org/jira/browse/DERBY-1544

Dan.

Mime
View raw message