db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kristian Waagan (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-2800) Implement Clob.truncate for embedded driver
Date Mon, 11 Jun 2007 23:41:26 GMT

    [ https://issues.apache.org/jira/browse/DERBY-2800?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12503682
] 

Kristian Waagan commented on DERBY-2800:
----------------------------------------

Had a look at the patch, and it looks very good. I have two comments:
 1) In ClobStreamControl.truncate, the wrong length is used for the check to reset the position
cache. The byte position is compared to the char position in the cache object. I think 'length'
should be renamed to 'byteLength' and 'newLength' possibly to 'newCharLength'. Thanks for
fixing the existing bug in there.

 2) ClobStreamControl.copyClobContent(InternalClob,long) should use more verbose variable
names, like 'charLength' and 'byteLength'. The same could be done for the static method, even
if there is only one length variable there.

 3) The test has some spelling errors and unused imports.

I plan to add some more tests (I made some notes in the new jdbcapi/ClobTest), and I think
adding them to a separate class as you have is a nice idea to keep the size of the test classes
down.


thanks,

> Implement Clob.truncate for embedded driver
> -------------------------------------------
>
>                 Key: DERBY-2800
>                 URL: https://issues.apache.org/jira/browse/DERBY-2800
>             Project: Derby
>          Issue Type: Sub-task
>          Components: JDBC
>    Affects Versions: 10.3.0.0
>            Reporter: Anurag Shekhar
>            Assignee: Anurag Shekhar
>         Attachments: derby-2800.diff
>
>


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message