db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel John Debrunner <...@apache.org>
Subject Re: 10.3 blocker issue - DERBY-2728
Date Wed, 30 May 2007 16:01:10 GMT
Rick Hillegas wrote:

> It appears to me that three solutions have been proposed:
> 
> 1) Call the release 11.0 rather than 10.3. That is, accept the 
> incompatibilities.

I don't actually see how changing the version number helps, it's still 
incompatible.

> 2) Add an extra security knob. The default setting would be the old 10.2 
> behavior.

-0.9 Adding properties is not good for the long run, leads to increased 
complexity support cost as the number of permutations of runtime modes 
increases.

> 3) Only restrict upgrade/encrypt/shutdown powers to the DBO if both 
> authorization and authentication are turned on. This does not eliminate 
> the incompatibilities but should greatly reduce the number of affected 
> customers.
> 
> My vote is for option (3).

+1 for 3)

Dan.

Mime
View raw message