db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bernt M. Johnsen" <Bernt.John...@Sun.COM>
Subject Should the property be named derby.connection.sslMode or derby.drda.sslMode?
Date Mon, 21 May 2007 11:21:11 GMT
When I implemented SSL I named the property for setting the ssl mode
of the server
  derby.drda.sslMode
to be conform with naming in the other server-related properties
  derby.drda.startNetworkServer
  derby.drda.logConnections
  derby.drda.traceAll
  derby.drda.trace
  derby.drda.traceDirectory
  derby.drda.minThreads
  derby.drda.maxThreads
  derby.drda.timeSlice
  derby.drda.securityMechanism
  derby.drda.portNumber
  derby.drda.host
  derby.drda.keepAlive
  derby.drda.streamOutBufferSize

while working with the documentation of SSL I noticed the property
  derby.connection.requireAuthentication
which is the only derby.connection.* property

It is obvious that "drda" is not a very good name here (unless the
property is drda-related, which none of the above are, except
derby.drda.securityMechanism which relates directly to a DRDA
mechanism) since it is just an implementation detail that we use DRDA.

So to my questions:
1) Should I name the property "derby.connection.sslMode"?
2) Should we have a policy for moving away from "derby.drda.*" for
server-related properties which are not related to DRDA?

If the answer to 1) is "no", I find it natural that
derby.connection.requireAuthentication was renamed to
derby.drda.requireAuthentication.

-- 
Bernt Marius Johnsen, Database Technology Group, 
Staff Engineer, Technical Lead Derby/Java DB
Sun Microsystems, Trondheim, Norway

Mime
View raw message