db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kathey Marsden (JIRA)" <j...@apache.org>
Subject [jira] Updated: (DERBY-2378) SecureServerTest should not be using non-public apis
Date Mon, 14 May 2007 16:15:16 GMT

     [ https://issues.apache.org/jira/browse/DERBY-2378?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kathey Marsden updated DERBY-2378:
----------------------------------

    Fix Version/s: 10.3.0.0

> SecureServerTest  should not be using non-public apis
> -----------------------------------------------------
>
>                 Key: DERBY-2378
>                 URL: https://issues.apache.org/jira/browse/DERBY-2378
>             Project: Derby
>          Issue Type: Bug
>          Components: Test
>    Affects Versions: 10.3.0.0
>            Reporter: Daniel John Debrunner
>         Assigned To: Rick Hillegas
>             Fix For: 10.3.0.0
>
>         Attachments: derby-2378-01.diff
>
>
> Functional tests should not be written against Derby's public api, not its internals.
> One reason is that it will make it harder to run the tests against different versions
of Derby to test for regressions (e.g. run 10.3 tests against 10.4)
> The code imports these classes that are not part of the public api.
> import org.apache.derby.iapi.reference.Property;
> import org.apache.derby.iapi.tools.i18n.LocalizedResource;
> import org.apache.derby.impl.drda.NetworkServerControlImpl;

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message