db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kim Haase (JIRA)" <j...@apache.org>
Subject [jira] Updated: (DERBY-2538) Update documentation to describe the expected behavior when a JDBC 4 app creates a JDBC 3 datasource.
Date Fri, 13 Apr 2007 14:22:15 GMT

     [ https://issues.apache.org/jira/browse/DERBY-2538?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kim Haase updated DERBY-2538:
-----------------------------

    Attachment: DERBY-2538-3.zip
                DERBY-2538-3.diff

Whoops! Sorry about that. Here is a clean patch, I hope. Thanks for catching that.

After reading DERBY-2488, I am wondering if the description of the client DataSource interfaces
in the Admin Guide (both cadminnsdatasources.dita and cadminappsxawthdriver.dita) ought to
have some version of the following text in rdevresman79556.dita:

"If an application is running on the Java SE 6 platform, all connection objects 
returned from the DataSource will be JDBC 4 connection objects, 
regardless of which DataSource variant is in use."

That is, assuming DERBY-2488 continues in the same direction it seems to be heading. I agree
it makes sense to wait on completing this issue till that issue is resolved.

> Update documentation to describe the expected behavior when a JDBC 4 app creates a JDBC
3 datasource.
> -----------------------------------------------------------------------------------------------------
>
>                 Key: DERBY-2538
>                 URL: https://issues.apache.org/jira/browse/DERBY-2538
>             Project: Derby
>          Issue Type: Sub-task
>          Components: Documentation
>    Affects Versions: 10.2.2.0, 10.3.0.0
>            Reporter: A B
>         Assigned To: Kim Haase
>            Priority: Minor
>         Attachments: cdevresman89722.html, DERBY-2538-2.diff, DERBY-2538-2.zip, DERBY-2538-3.diff,
DERBY-2538-3.zip, DERBY-2538.diff, rdevresman79556.html
>
>
> Based on discussion from DERBY-2488, pages in the Developer's Guide should be improved
to describe what happens if a JDBC 4 application uses an "old" (JDBC 3) datasource.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message