db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Suresh Thalamati <suresh.thalam...@gmail.com>
Subject Re: [jira] Commented: (DERBY-2254) Assert during log file switch: log file position exceeded max log file size
Date Wed, 07 Mar 2007 20:12:07 GMT

Hi Olav,

Thanks a lot for spending time to find the cause for the large log 
files. My comments are in-line.

Olav Sandstaa wrote:
> Suresh

> Suresh Thalamati wrote:
> 
>> Olav Sandstaa (JIRA) wrote:
>>
>>>     [ 
>>> https://issues.apache.org/jira/browse/DERBY-2254?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12466475

>>> ]
>>> Olav Sandstaa commented on DERBY-2254:
>>> --------------------------------------

> 
> I have tried running with these settings and the resulting 3.2 GB 
> derby.log file contains the dump of about 16 million log records. The 
> last entries in the log are:
> 
>
<snip > ..
> 
> As you suggested, I tried to look for any sign of whether a checkpoint 
> was in progress or not. But from the dump of the log I can not find any 
> sign of checkpoints in the entire log. Do you have any suggestions for 
> how a checkpoint would identify itself in the log dump?

Checkpoint in the log trace , should look something like the following :

DEBUG LogTrace OUTPUT: scanned 160 : Checkpoint :       redoLWM (1,49176)
                 undoLWM (1,49176)
**************************
org.apache.derby.impl.store.raw.xact.TransactionTable@bf7190

..etc.


I was thinking there should be a checkpoint in log files around
the large log files,(log1191.dat (log1191.dat  log1198.dat ..)
not necessarily in the them.

Only other reason I can think for not finding a checkpoint  is ,
it started in the beginning and never finished. If this the case
then I am confused how it managed to generate ~1MB log files in
between those large ones.



> 
> If I try to categorize the entries in the log dump they fall into the 
> following types (with the number of occurrences  in the first column):
> 
> 11422649   Page Operation:
> 2340723    BeginXact
> 2340734    EndXact
> 420947     Checksum Operation
> 29         detected proper log end on log file
> 29         switched to next log file
> 
> None of these seems to indicate that a checkpoint have started?
> 

you are correct, those records can not confirm that the checkpoint in 
progress. Checkpoint log records is written only after all the data
is flushed, in your test case failure seems to have occured while
writing a checkpoint record.  Looking at the last entries may not be
be useful.

Thanks
-suresht


Mime
View raw message