db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Julius Stroffek (JIRA)" <j...@apache.org>
Subject [jira] Created: (DERBY-2434) HarnessJavaTest fails on UTF-8 locale.
Date Fri, 09 Mar 2007 17:11:09 GMT
HarnessJavaTest fails on UTF-8 locale.
--------------------------------------

                 Key: DERBY-2434
                 URL: https://issues.apache.org/jira/browse/DERBY-2434
             Project: Derby
          Issue Type: Bug
          Components: Test
    Affects Versions: 10.3.0.0
         Environment: Solaris Nevada - build 56, Sun JDK1.6
            Reporter: Julius Stroffek
             Fix For: 10.3.0.0


The HarnessJavaTest fails to me all the time with the following error:
statementJdbc20(org.apache.derbyTesting.functionTests.tests.jdbcapi.JDBCHarnessJavaTest)junit.framework.ComparisonFailure:
Output at line 3 expected:<... parameter value '-1[,]000' for Statement.s...> but was:<...
parameter value '-1[��]000' for Statement.s...>
        at org.apache.derbyTesting.functionTests.util.CanonTestCase.compareCanon(CanonTestCase.java:100)
        at org.apache.derbyTesting.functionTests.util.HarnessJavaTest.runTest(HarnessJavaTest.java:91)
        at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:76)
        at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
        at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
        at junit.extensions.TestSetup.run(TestSetup.java:25)
        at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
        at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
        at junit.extensions.TestSetup.run(TestSetup.java:25)
        at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
        at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
        at junit.extensions.TestSetup.run(TestSetup.java:25)

There is only a difference in encoding a comma in statementJdbc20.out file on 3 lines.

I have the following locale setup:
LANG=en_US.UTF-8
LC_CTYPE=sk_SK.UTF-8
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES=en_US.UTF-8
LC_ALL=

I think It has something to do with my locale setup but I have not checked this yet.

On my output, instead of comma, there are 2 bytes - C2 A0

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message