db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mamta Satoor" <msat...@gmail.com>
Subject Re: Running junit suites.All in same directory as harness gets "wombat already exists"?
Date Mon, 05 Feb 2007 00:09:30 GMT
Bryan, I follow the same steps as you that is run derbyall and follow is
right away with Junit All suite. I haven't seen the problem you are
encountering. I wonder if some test failed in derbyall and it left the
wombat database after the failure.


On 2/4/07, Bryan Pendleton <bpendleton@amberpoint.com> wrote:
> I have this habit of running the tests by typing:
> java org.apache.derbyTesting.functionTests.harness.RunSuite derbyall;
> java junit.textui.TestRunner
> org.apache.derbyTesting.functionTests.suites.All
> That is, both commands consecutively in the same directory.
> The last time I tried this, I got a bunch of errors during the Junit
> tests about "Failed to create database 'wombat'... directory already
> exists".
> When I run the Junit tests in an empty directory by themselves, no
> problem.
> Anybody else seeing this?
> thanks,
> bryan

View raw message