db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kristian Waagan (JIRA)" <j...@apache.org>
Subject [jira] Updated: (DERBY-2359) Code cleanups for the org.apache.derby.impl.store.access.* packages
Date Tue, 20 Feb 2007 14:13:05 GMT

     [ https://issues.apache.org/jira/browse/DERBY-2359?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kristian Waagan updated DERBY-2359:
-----------------------------------

    Attachment: derby-2359-1a-unused_imports.stat
                derby-2359-1a-unused_imports.diff

Removed unused imports from the "access layer" packages.
This is how diffstat summarizes it:
147 files changed, 82 insertions(+), 905 deletions(-)

Changes:
 - removal of unused imports
 - reordering of imports where I had already removed many
 - moved/reformatted some class JavaDocs
 - deleted some whitespace (blank lines due to removed imports)

I rebuilt and ran suites.All/derbyall without failures (except for the metadata fauilure).

I have one question:
In some of the classes, there are imports for other classes in the same package. Is it okay
to remove these, or where they added to document something?

The patch version 1a is not for commit. I will upload 1b in a day or two and commit it if
I get no pushback. The only change will be removal of more of the "same package" imports.

> Code cleanups for the org.apache.derby.impl.store.access.* packages
> -------------------------------------------------------------------
>
>                 Key: DERBY-2359
>                 URL: https://issues.apache.org/jira/browse/DERBY-2359
>             Project: Derby
>          Issue Type: Improvement
>          Components: Store
>    Affects Versions: 10.3.0.0
>            Reporter: Kristian Waagan
>         Assigned To: Kristian Waagan
>            Priority: Minor
>         Attachments: derby-2359-1a-unused_imports.diff, derby-2359-1a-unused_imports.stat
>
>
> When trying to learn more about the access layer, it was discovered that some code improvements
could easily be made to increase the readability of the code.
> Patches attached to this issue will be cleanup patches only, and no functionality should
be changed. 
> Changes the will/may be made:
>  * remove unused imports
>  * remove unused methods
>  * fix JavaDoc errors
>  * tighter encapsulation and removal of unused variables where appropriate

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message