db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kristian Waagan (JIRA)" <j...@apache.org>
Subject [jira] Updated: (DERBY-2359) Code cleanups for the org.apache.derby.impl.store.access.* packages
Date Wed, 21 Feb 2007 17:45:05 GMT

     [ https://issues.apache.org/jira/browse/DERBY-2359?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Kristian Waagan updated DERBY-2359:

    Attachment: derby-2359-1b-unused_imports.stat

'derby-2359-1b-unused_imports.diff' removes unused imports, also import for classes in the
same package as the importing class. Updated diffstat:
63 files changed, 81 insertions(+), 490 deletions(-)

I was a bit too eager, and removed unused imports for store.raw as well as store.access. I
have split the patch into two, and will create a new Jira for the store.raw packages.

Also note that I had to change some JavaDoc @see tags due to the removed imports. Where the
package names got too long, I imported the class instead and added a comment, like this:
// For JavaDoc references (i.e. @see)
import org.apache.derby.iapi.store.access.conglomerate.MethodFactory;

I plan to commit this patch tomorrow.

> Code cleanups for the org.apache.derby.impl.store.access.* packages
> -------------------------------------------------------------------
>                 Key: DERBY-2359
>                 URL: https://issues.apache.org/jira/browse/DERBY-2359
>             Project: Derby
>          Issue Type: Improvement
>          Components: Store
>    Affects Versions:
>            Reporter: Kristian Waagan
>         Assigned To: Kristian Waagan
>            Priority: Minor
>         Attachments: derby-2359-1a-unused_imports.diff, derby-2359-1a-unused_imports.diff,
derby-2359-1a-unused_imports.stat, derby-2359-1a-unused_imports.stat, derby-2359-1b-unused_imports.diff,
> When trying to learn more about the access layer, it was discovered that some code improvements
could easily be made to increase the readability of the code.
> Patches attached to this issue will be cleanup patches only, and no functionality should
be changed. 
> Changes the will/may be made:
>  * remove unused imports
>  * remove unused methods
>  * fix JavaDoc errors
>  * tighter encapsulation and removal of unused variables where appropriate

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message