db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Knut Anders Hatlen (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-2191) Cleanup of FormatableBitSet
Date Thu, 25 Jan 2007 14:05:49 GMT

    [ https://issues.apache.org/jira/browse/DERBY-2191?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12467385

Knut Anders Hatlen commented on DERBY-2191:

I think the rewrite of numBitsInLastByte() made the code clearer. The error checks in the
constructor and shrink() also seem useful. Two comments:
  1) umul8() doesn't seem to be used.
  2) I think isSet(), set() and clear() became more difficult to read. I think it would be
better if they kept the old style where the byte number and bit position were calculated separately
and put into variables with meaningful names (they can still use the new methods).

> Cleanup of FormatableBitSet
> ---------------------------
>                 Key: DERBY-2191
>                 URL: https://issues.apache.org/jira/browse/DERBY-2191
>             Project: Derby
>          Issue Type: Improvement
>          Components: Miscellaneous
>    Affects Versions:
>            Reporter: Dyre Tjeldvoll
>         Assigned To: Dyre Tjeldvoll
>            Priority: Trivial
>             Fix For:
>         Attachments: bitops.v1.diff, bitops.v1.stat, bitops.v2.diff, bitops.v2.stat,
bitops.v3.diff, bitopt.v1.diff, bitopt.v1.stat, boundarycheck.v1.diff, boundarycheck.v1.stat,
cleanup2191.diff, cleanup2191.stat, deadcode.v1.diff, deadcode.v2.diff, fbstst.v1.diff, fbstst.v1.stat,
FormatableBitSetTest.java, unusedmethods.v1.diff, unusedmethods.v1.stat, valuenotnull.v1.diff,
> The implementation of FormatableBitSet could be streamlined. Dead code can be removed
and the implementation of some methods can be simplified.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message