db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Knut Anders Hatlen <Knut.Hat...@Sun.COM>
Subject Re: [jira] Commented: (DERBY-1471) Implement layer B streaming for new methods defined in JDBC4.0
Date Thu, 07 Dec 2006 13:42:54 GMT
TomohitoNakayama <tomonaka@basil.ocn.ne.jp> writes:

> Thank you for your attention.
>
> I think another patch is needed before committing ...

Thank you for taking my comments into consideration.

>>* Blob/Clob: The variable willBeLayerBStreamed_ and the method
>>  willBeLayerBStreamed() could be moved to the base class (Lob) to
>>  avoid duplicated code.
>>
> I am somewhat repulsed for sharing code around instance variable ....
>
> However, the value never be changed in the life of the object and
> they are equal in semantics ....

In that case I think it would be good to declare the variable as final
as well. Seems like it is initialized in the constructor and is newer
changed, so that should work.

-- 
Knut Anders

Mime
View raw message