db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew McIntyre" <mcintyr...@gmail.com>
Subject Re: Re: Re: build error ?
Date Wed, 06 Dec 2006 18:38:17 GMT
On 12/6/06, Mamta Satoor <msatoor@gmail.com> wrote:
> The build does not give any errors after the import SanityManager checkin.
> Thanks, Andrew. I still don't understand why I was getting "class file has
> wrong version 50.0, should be 48.0" rather than the real compilation error.

Maybe the real compilation error happened earlier but you missed it?

I'm guessing that what was going on here was that something in the
same target as EmbedXADatabase was not getting compiled because of the
compilation failure in EmbedXADatabase. Then, that class was later
side-compiled in the jdbc4 target because it hadn't already been
compiled in its normal target, and the version in the classfile was
set to 50.0. A little further down the line, the compiler tries to
compile a class that imports the class which got side-compiled in the
jdbc4 target, but has target=1.4 set, tries to load the class that got
side-compiled in the jdbc4 target, notices the version is set to 50.0
- incompatible with a target=1.4 compile - and issues the "wrong
version" error.

andrew

Mime
View raw message