db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jean T. Anderson" <...@bristowhill.com>
Subject Re: [jira] Commented: (DERBY-2129) Tasks related to releasing 10.2.2
Date Mon, 11 Dec 2006 23:13:43 GMT
Daniel John Debrunner (JIRA) wrote:
>     [ http://issues.apache.org/jira/browse/DERBY-2129?page=comments#action_12457501 ]

>             
> Daniel John Debrunner commented on DERBY-2129:
> ----------------------------------------------
> 
> The reference guide still has this disclaimer about JDBC 4, should it be removed?
> 
> db-derby-10.2.2.0-bin/docs/html/ref/crefjdbc12657.html
> 
> Note that an application run on Java SE 6 uses the JDBC4 versions of Derby's JDBC drivers.
In that environment, Derby's two JDBC drivers, the embedded driver and the network client
driver, implement an early access (late beta) version of the JDBC4 specification. It is possible
that the final version of the JDBC4 specification may differ from the early access version
available when this manual was written. We expect such discrepancies to be minor. These discrepancies,
if any, are documented in the 10.2 Release Notes.

I removed that, revision 485927, but was a little puzzled because that
warning wasn't implemented via the DITA conref I undid last week.

In fact, that was put into the trunk, revision 434159 (then merged to
the 10.2 branch), as part of DERBY-1731. (It wasn't completely correct
for 10.2.1.6, which actually used the JDBC 3 drivers on Java SE 6 unless
developers rebuilt with 4.0 support.)

At any rate, I think that needs to be removed from the trunk and will do
so unless somebody thinks it needs to stay.

 -jean

Mime
View raw message