db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel John Debrunner (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-2107) Move page latching out of the lock manager
Date Thu, 14 Dec 2006 22:32:22 GMT
    [ http://issues.apache.org/jira/browse/DERBY-2107?page=comments#action_12458628 ] 
Daniel John Debrunner commented on DERBY-2107:

I think the patch hit this issue due to some existing confusion with naming in the existing

The top level api currently is
   Page page = ContainerHandle.getPage()
   // do stuff with page

and then internally the page code uses a lock manager Latch to help manage its lifecyle.

As latching moves into the page implementation it might make sense to rename concepts to maintain
a clear separation.

Maybe the top-level api could use release() instead of unlatch() and leave the latch concept
for the code Knut has implemented.
Obviously changing/cleaning up the comments in the various .getPage() calls to reflect the
new terminology would be required as well.

> Move page latching out of the lock manager
> ------------------------------------------
>                 Key: DERBY-2107
>                 URL: http://issues.apache.org/jira/browse/DERBY-2107
>             Project: Derby
>          Issue Type: Improvement
>          Components: Store, Services, Performance
>    Affects Versions:
>            Reporter: Knut Anders Hatlen
>         Assigned To: Knut Anders Hatlen
>            Priority: Minor
>         Attachments: derby-2107-1a.diff, derby-2107-1a.stat, derby-2107-1b.diff
> Latching of pages could be done more efficiently locally in store than in the lock manager.
See the discussion here: http://thread.gmane.org/gmane.comp.apache.db.derby.devel/33135

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message