db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frederik (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-2136) Can't set system directory with derby.system.home for Network Server
Date Sat, 02 Dec 2006 10:56:21 GMT
    [ http://issues.apache.org/jira/browse/DERBY-2136?page=comments#action_12455089 ] 
            
Frederik commented on DERBY-2136:
---------------------------------

I was doing these tests at the office, I will only be able to access it on Monday. All stuff
below is taken from memory. 

I was using Apache Derby 10.2.1.6. The JVM was 1.4.2. OS Solaris 9. 

I did not try to create a db when I tested this, but I tried to simply connect to a DB 'testdb'
that was in /data/derby, created earlier in embedded mode.

For that I did (after starting Network Server)

ij 
ij> connect 'jdbc:derby://localhost/testdb' ;

Only if Network Server was started with "export DERBY_OPTS=-Duser.dir=/data/derby", did my
connect work.

> Can't set system directory with derby.system.home for Network Server
> --------------------------------------------------------------------
>
>                 Key: DERBY-2136
>                 URL: http://issues.apache.org/jira/browse/DERBY-2136
>             Project: Derby
>          Issue Type: Bug
>          Components: Documentation, Network Server
>            Reporter: Frederik
>            Priority: Minor
>
> I'm a total newcomer to Derby. Decided to play with it today after reading http://www.regdeveloper.co.uk/2006/11/08/java_database_derby
> I want to use the Network Server deployment mode. For determining the System Directory
(which holds properties file and the database directories, etc), I understood from docs (e.g.
http://db.apache.org/derby/docs/10.2/devguide/cdevdvlp27610.html) that I should set derby.system.home.

> I tried (using the newer scripts in $DERBY_HOME/bin)
> export DERBY_OPTS=-Dderby.system.home=/data/derby 
> startNetworkServer
> but that failed to set the system directory properly (as witnessed by "NetworkServerControl
sysinfo"). It was using current directory when starting derby.
> I finally discovered that it works if I do 
> export DERBY_OPTS=-Duser.dir=/data/derby 
> startNetworkServer
> That seems to be either a bug or a docbug to me. 
> (Almost all docs are using the scripts in $DERBY_HOME/frameworks/NetworkServer/bin instead
of the newer ones in ./bin ; except for http://db.apache.org/derby/docs/10.2/getstart/ and
the mention in 10.2 release notes)

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message