db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel John Debrunner (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-1983) Change build system so that base level is JDK 1.4
Date Tue, 14 Nov 2006 16:59:38 GMT
    [ http://issues.apache.org/jira/browse/DERBY-1983?page=comments#action_12449703 ] 
            
Daniel John Debrunner commented on DERBY-1983:
----------------------------------------------

I do think that Derby should be buildable using jdk 1.4 or jdk 1.5, but I think Derby should
still run on JDK 1.4 and I'm willing to scratch that itch.

I saw some article on the web that indicated most Java developers have not switched to 1.5
and are still based on 1.4.2.
I do not believe we should restrict the potential pool of Derby developers by requiring JDK
1.5 (or JDK 6) to build Derby.

Since JDBC 3 is the JDBC support level for 1.4 and 1.5 having the build work with either should
be fine.

> Change build system so that base level is JDK 1.4
> -------------------------------------------------
>
>                 Key: DERBY-1983
>                 URL: http://issues.apache.org/jira/browse/DERBY-1983
>             Project: Derby
>          Issue Type: Sub-task
>          Components: Build tools
>            Reporter: Daniel John Debrunner
>


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message