db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bryan Pendleton (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-2030) 'set schema sys' followed by 'show tables' does not show tables in sys schema
Date Sat, 04 Nov 2006 16:08:18 GMT
    [ http://issues.apache.org/jira/browse/DERBY-2030?page=comments#action_12447157 ] 
            
Bryan Pendleton commented on DERBY-2030:
----------------------------------------

Hi Andrew, I applied the patch and it seems to work fine for me. I can see the behavior changes
and they are as I expected. I think the new behavior is reasonable.

Are there no tests for this feature in our test suite? I was a little bit surprised that there
were no test changes in this patch.



> 'set schema sys' followed by 'show tables' does not show tables in sys schema
> -----------------------------------------------------------------------------
>
>                 Key: DERBY-2030
>                 URL: http://issues.apache.org/jira/browse/DERBY-2030
>             Project: Derby
>          Issue Type: Bug
>          Components: Tools
>    Affects Versions: 10.2.1.6, 10.3.0.0
>            Reporter: Andrew McIntyre
>         Assigned To: Andrew McIntyre
>            Priority: Minor
>         Attachments: ij_showalltables.diff
>
>
> If you create a new database in IJ, followed by 'set schema sys' and then 'show tables',
ij shows no tables in the schema. This is because ij's show tables command only shows system
tables if a schema is provided.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message