db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel John Debrunner (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-1983) Change build system so that base level is JDK 1.4
Date Tue, 14 Nov 2006 21:36:38 GMT
    [ http://issues.apache.org/jira/browse/DERBY-1983?page=comments#action_12449803 ] 
            
Daniel John Debrunner commented on DERBY-1983:
----------------------------------------------

I think Andrew's method above works but will silently allow JDK 1.5 methods and/or classes
to be used which are not present in JDK 1.4.

The documentation for Javac has this example for cros compilation:

javac -target 1.4 -bootclasspath jdk1.4.2/lib/classes.zip \
             -extdirs "" OldCode.java

and a note about needing to point the compiler to a different set of base classes.

> Change build system so that base level is JDK 1.4
> -------------------------------------------------
>
>                 Key: DERBY-1983
>                 URL: http://issues.apache.org/jira/browse/DERBY-1983
>             Project: Derby
>          Issue Type: Sub-task
>          Components: Build tools
>            Reporter: Daniel John Debrunner
>


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message