db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kristian Waagan (JIRA)" <derby-...@db.apache.org>
Subject [jira] Created: (DERBY-1971) Make TestConfiguration set descriptive names for TestSuite objects it instantiates
Date Tue, 17 Oct 2006 17:48:37 GMT
Make TestConfiguration set descriptive names for TestSuite objects it instantiates
----------------------------------------------------------------------------------

                 Key: DERBY-1971
                 URL: http://issues.apache.org/jira/browse/DERBY-1971
             Project: Derby
          Issue Type: Improvement
          Components: Test
    Affects Versions: 10.3.0.0
            Reporter: Kristian Waagan
            Priority: Minor


Several JUnit tools make use of TestSuite.getName() to display test hierarchies and other
information. An example is junit.swingui.TestRunner.
Currently, the TestSuite objects generated by TestConfiguration are not given names.
To improve readability and the level of information, descriptive named should be set. At a
minimum, the associated framework should be indicated. Another point is whether the user set
name (if any) of the "root test suite" should be propagated or not.


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message