db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myrna van Lunteren" <m.v.lunte...@gmail.com>
Subject q re XA transactions and test checkDataSource
Date Mon, 25 Sep 2006 14:02:40 GMT
Hi,

In connection to trying to do remote server / IPV6 testing for the
release candidate, I ran into some behavior in the test
checkDataSource that I'm trying to understand.
I don't think there's a bug, but I do need some help.

The problem is that the test doesn't clean up after itself. Thus,
subsequent tests - e.g. checkDataSource30 - (which run on the same
database with remote server testing) fail.

This test used to pass because of a subtest that used to get skipped
for DerbyNetClient.

The problem I'm having is trying to drop the table ru at the end of
the test. There's a lock on it.
The lock gets set after this line in the test:
-------------------------------
	showStatementState("CS GLOBAL ", csruState);
	resultSetQuery("Params-global-1", psParams.executeQuery());
-->	xar.end(xid, XAResource.TMSUCCESS);

My question is: how can I release the locks?
I've tried closing all statements and committing/rolling back all
connections I can see, but still the lock remains, or whatever I'm
attempting gives an error. I probably need to reattach a resource to a
connection?
Something like:
	xar.start(xid, XAResource.TMNOFLAGS);
?
But what I tried so far didn't work (I've tried so many probably
non-sensible things at this point to even mention them).
How do I do this?

Thx,
Myrna

Mime
View raw message