db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myrna van Lunteren" <m.v.lunte...@gmail.com>
Subject Re: [jira] Updated: (DERBY-1271) Release documentation for JDBC4 release
Date Wed, 13 Sep 2006 23:57:51 GMT
On 9/13/06, Jean T. Anderson <jta@bristowhill.com> wrote:
> Jean T. Anderson (JIRA) wrote:
> ...
> > I tried to shorten the notice and here's what I came up with, and I think it would
be good to shorten more:
> >
> > JDBC 4.0 functionality is not enabled in this Derby release because JDBC 4.0 is
part of Java SE 6, which was not generally available when the Derby release was produced.
When Derby is used with a Java SE 6 virtual machine, JDBC 3.0 will be available. JDBC 4.0
will only be available to developers who download Java SE 6 and use it to add JDBC 4.0 support
to Derby. The Release Notes provide details on how to build this optional JDBC 4.0 functionality,
but the result might not be compatible with the final version of JDBC 4.0. When Java SE 6
becomes generally available a follow-on Derby release will include final JDBC 4.0 functionality.
>
> "provide details on" -> "explain"
>
> :-)
>
> truly, the notice looks lengthy in the html output. less is more.
>
>  -jean
>
Ok, taking that and massaging...How about:

This release includes JDBC 4.0 functionality based on a pre-release of
Java SE 6. By default, when Derby is used with a Java SE 6 virtual
machine, JDBC 3.0 will be available. The Release Notes provide details
on how to build the optional JDBC 4.0 functionality after downloading
Java SE 6, but the result might not be compatible with the final
version of JDBC 4.0. When Java SE 6 becomes generally available a
subsequent Derby release will include support for the final JDBC 4.0.
functionality.

Myrna

Mime
View raw message