db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John H. Embretsen (JIRA)" <derby-...@db.apache.org>
Subject [jira] Commented: (DERBY-1846) Create a script that allows users to easily update their Derby jars with the JDBC4 classes.
Date Tue, 19 Sep 2006 10:26:52 GMT
    [ http://issues.apache.org/jira/browse/DERBY-1846?page=comments#action_12435742 ] 
            
John H. Embretsen commented on DERBY-1846:
------------------------------------------

I tried the 'update-with-jdbc4' script on a Solaris box (default shell is bash), and it failed
with the message 

"The JVM in $JAVA_HOME is not version 1.6.0
To use this script to compile the JDBC 4.0 Derby classes,
you need a 1.6.0 level VM"

But $JAVA_HOME was indeed set to a JDK 1.6 installation before running the script.

There seems to be a problem with the following check in the script:

if [ -z "$JAVA_HOME" ]; then
  if [ -n "$darwin" ]; then
    JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Home
  fi else if [ -d /usr/j2se -a -x /usr/j2se/bin/javac ]; then
    JAVA_HOME=/usr/j2se
  fi
fi

I say this because in my environment, JAVA_HOME is always set to /usr/j2se by the script (I
added an echo statement to verify this), and since that location contains a JDK 1.4.2 installation,
the subsequent version check fails (I later modified the script so that it would echo something
if the first condition shown above is true. It did not, meaning that JAVA_HOME was set, but
that the script modified it anyway).

Perhaps an if - elif - fi construct may be more usable in the Bourne shell?



> Create a script that allows users to easily update their Derby jars with the JDBC4 classes.
> -------------------------------------------------------------------------------------------
>
>                 Key: DERBY-1846
>                 URL: http://issues.apache.org/jira/browse/DERBY-1846
>             Project: Derby
>          Issue Type: Improvement
>          Components: Demos/Scripts
>    Affects Versions: 10.2.1.0
>            Reporter: Andrew McIntyre
>         Assigned To: Andrew McIntyre
>             Fix For: 10.2.1.0
>
>         Attachments: derby-1846-v1.diff, derby-1846-v2.diff
>
>
> Since the resolution of the JDBC 4 licensing issue was to not ship a build that includes
Derby's JDBC 4 code, but continue to ship the Derby source files for them, a script which
automatically compiles and updates the Derby jars with the JDBC 4 classes would be useful.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message